Intermittent Errors and Elevated Latency

Incident Report for Procore Technologies

Resolved

This incident has been resolved and application functionality is working as expected.
Posted Jun 30, 2026 - 06:10 PDT

Monitoring

Our engineering team has implemented a fix for the issue causing intermittent errors and elevated latency for a subset of our users. To ensure a complete resolution, we will be working on our platform between 8:00 PM PT - 8:30 PM PT. During this time, some users may experience brief, intermittent disruptions for a short period.

We will provide an additional update when full resolution is reached.
Posted Jun 29, 2026 - 18:19 PDT

Identified

Our engineering team has identified the cause of the intermittent errors and elevated latency affecting some customers. We are actively working to implement a solution to restore full performance.

We will continue to provide updates as progress is made.
Posted Jun 29, 2026 - 14:14 PDT

Update

We are continuing to investigate this issue.
Posted Jun 29, 2026 - 11:45 PDT

Update

Our engineering team continues to investigate intermittent errors and elevated latency affecting some customers. We are actively working toward full resolution.

Some customers may notice that automatic ERP syncing is unavailable at this time. Manual syncs are still possible and can be initiated by ERP admins.

Additional updates will be provided within the next hour.
Posted Jun 29, 2026 - 10:38 PDT

Update

Our engineering team is continuing to investigate intermittent errors and elevated latency affecting some customers. We have implemented improvements that have helped to reduce the impact, and we are continuing to work toward full resolution.

Some customers may notice that automatic ERP syncing is unavailable at this time. Manual syncs are still possible and can be initiated by ERP admins.

Additional updates will be provided within the next hour.
Posted Jun 29, 2026 - 09:39 PDT

Update

Our engineering team continues to investigate intermittent errors and elevated latency affecting some customers. We have implemented improvements that have reduced the impact, and we are continuing to work toward full resolution.

Some customers may notice that automatic ERP syncing is unavailable at this time. Manual syncs are still possible and can be initiated by ERP admins.

Additional updates will be provided within the next hour.
Posted Jun 29, 2026 - 08:41 PDT

Update

Our engineering team continues to investigate the intermittent errors and elevated latency affecting some customers and is actively working to implement a fix. We will continue to provide updates as progress is made.
Posted Jun 29, 2026 - 08:23 PDT

Investigating

Our engineering team is investigating intermittent errors and elevated latency affecting some customers. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Jun 29, 2026 - 04:45 PDT
This incident affected: Global Services (Web Interface).